Some outgoing emails may be delayed or not delivered
Resolved
Jan 19 at 04:00pm EET
All email communications have been resolved. If you're still having any issues all your data is available in your account.
Affected services
Updated
Jan 14 at 11:48am EET
We have identified the root cause and are working towards resolving this. The emails of Krotos Studio usage are being delivered as expected.
Affected services
Created
Jan 09 at 10:20am EET
We’re currently experiencing limited delivery of outgoing emails. This means some emails (such as order confirmations or notifications) may arrive later than usual or not at all.
All core systems are working normally:
- Orders are processing as expected
- Accounts and dashboards are fully accessible
- You can view all orders and updates directly from your account pages
We’re actively working to restore normal email delivery and will share updates here as progress continues. Thank you for your patience.
Affected services