Back to overview
Degraded
Checkout not working
May 22, 2025 at 4:27pm UTC
Affected services
krotos.studio
Resolved
May 23, 2025 at 9:37am UTC
Checkout now working
Affected services
Created
May 22, 2025 at 4:27pm UTC
Checkout stopped working for roughly 15 hours. It is working again but maintenance is ongoing to fix the root of the issue.
Affected services