Back to overview
Degraded

Unable to checkout

Jul 06 at 02:12am EEST
Affected services
krotos.studio

Resolved
Jul 06 at 02:33am EEST

We've identified and resolved the issue. The fix is deploying on all regions as of this moment.

Thank you for your patience.

Created
Jul 06 at 02:12am EEST

Thank for your response in the Krotos Studio Pro release.

It appears our payment gateways have taken a beating. Currently you’ll be getting an error when trying to checkout.

We are working on resolving that issue as soon as we can, so you’ll be able to get your hands on Krotos Studio.